wsonor USING EXcel to query
Finance Data Warehouse

Accessing the State Data Warehouse (StateDW) via Excel or other applications requires
ODBC settings to be configured. Users who do not currently have these settings should
create a DTS helpdesk ticket. DTS will then proceed with the installation and
configuration and will inform you upon completion

Instructions

B Excel

Good morning

{m

. ~ New
1. Open Excel, click Blank workbook. o ,
- Take a tour Formulas
0 - .
New Blank workbook Welcome to Excel Formula tutorial
B ‘ £ Search

Open

Recent  Favorites Shared with Me

2. Click File > Options > Data, then check the box for From Microsoft Query (Legacy),
click OK (this step only needs to be completed the first time you set this up).

Bl Bookl - Excel

@ Excel Options ? X
. General . . . Q
{nl Home I:a’ Change options related to data import and data analysis.
Formulas
(3 New Data Data options
= Open T Make changes to the default layout of PivotTables: | Edit Default Layout... |
Save Disable undo for large PivotTable refresh operations to reduce refresh time
Info Language Disable undo for PivotTables with at |east this number of data source rows (in thousands): | 300
Accessibility [] Prefer the Excel Data Model when creating PivotTables, QueryTables and Data Cannections (I
T 3 Disable unda for large Data Model aperations.
Advanced _—
Disable undo far Data Madel operations when the madel is at least this large (in MB): | 8 2|
e Customize Ribbon [ Enable Data Analysis add-ins: Pawer Pivot and 3D Maps
Srra e Quick Access Toolbar ("] Disable automatic grouping of Date/Time columns in PivotTables
PDF Add-ins Show legacy data import wizards
Print Trust Center ] From Access (Legacy) ["] From OData Data Feed (Legacy)
[7) From Web (Legacy) ["] From XML Data Import (Legacy)
are rom Jext (Legac rom Data Connection Wizard (Legac D
Sh [7] From Text (Legacy) ["] From Data C Wizard (Legacy)

[ From SQL Server (Legacy) & From Microsoft Query (Legacy)

Export W
Automatic Data Conversion
Close . . "
B3 Enable all default data conversions below when entering, pasting, or loading text into Excel
B Remove leading zeros and convert to a number © u
B8 Keep first 15 digits of Jong numbers and display in scientific notation O]
B Convert digits surrounding the letter "E" to a number in scientific notation © i
& Convert continuous letters and numbers to a date 0]
Account Additional Options
& When loading a .csv file or similar file, notify me of any automatic data conversion - Ju
[ [XEIEE I
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-
u AutoSave 9~ - Book2 - Excel 2 search

File Home  Insert Draw  Page Layout Formulas | Data |Review View  Automate Help  Acrobat

. ] From Text/CSV E:@E'Frnm Picture ~ r [H Queries & Connections
2 @ g
[&RecentSources Refresh
. X = Stocks Currencies
| ) = ting Connections All~ D
3_ C||Ck Data > Get Data > |j From File 5 Queries & Connections Data Types
Legacy Wizards > From /
: [ From Database ar E F % H ) K
Microsoft Query ~ .
& From Azure b4
(Legacy) 2
3
4 ? From Power Platform >
5
6 @ From Online Services b4
T
a [3_0 From Other Sources b4
g
10) rEj Legacy Wizards > [?E From Microsoft Query (Legacy)
11
12 g Combine Queries >
13
14 @ Launch Power Query Editor...
::; [% Data Source Settings...
17| Query Options
18]

*

Choose Data Source

4. Select StateDW*, click OK. - )

. Databases | Queries | OLAP Cubes ]4 |
(if StateDW* does not appear, — __ | I |
. <Mew Data Source: o
create a DTS helpdesk ticket, 32t Cancal |}
. Datawarshouze® 4
they need to install and dBASE Files” Browse...
Excel Files® {

configure your ODBC settings to atebace” -
access State Data Warehouse). CS‘“EDW’}ﬁ

[relete

ddu

Ell v Use the Querny wizard to create/edit queries

A rE———
| Adaptive Server Enterprise 7
Logon
Server Name: |sldgnw_ﬁ1mm,uah Gov
. Server Port: |5355
5. Enter the password and click OK.
. . Database Name:

Your supervisor can provide the password oy

if you don't have it. ol jow
Password: Q | )

ok || camced | sppy |
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Query Wizard - Choose Columns X
6‘ Query lea.rd .- ChOOSE What columns of data do you want ta include in your query?
Columns will dlsplay. Available tables and columns: Columns in your query:
The left side will display the 8 Jiecounting_Jounal = =]
. . Account_Type j
table name, and the right side Accounting_Line_Number £
: : Activity |
will dlsplay the columns you i’
select. Click the + symbol to PSR
expand the tables tO VieW Preview of data in selected column:
columns. We have expanded [
to view the columns in the
Accounting Journal. ] | Prevenow | | Optorm.. . New> | [ ool ]
7. Click on the column name, and then select
the center arrow icon _: | to move it into ey Wizl s Colenrs X
the Ce” CO|UmnS in your query ‘What columns of data do you want to include in your query?
Available tables and columns: Il:alurnnsin your query: I
) Fiscal_Quarter ;I Account_Type j
(In this example we have selected the ] | Document Code =
Account Type, Amount, Document Code, Fnd < | [resaen

. . Funding_Line
Department and Fiscal Year columns. This Fogiko bivie

is where you select the columns you deSire s dsain seiected cohmn
for your output) |

Vi
After you have selected your columns, click @) _prevewtow | optons.. peck |[Nea> Cancel
Next.
Query Wizard - Filter Data X
Filter the data to specify which rows to include in your query.
If you don't want to filter the data, click Next.
Column to filter: Only include rows where:
Account_Type ~Departrment
. Amount [ -l ~|
8. Click on the Department column, then | |[Sexmen code | o
on the right-side select the empty cells | |Feelres e | =
. . . . 1z greater than
drop down. Choose your criteria, in this s reatr than orequalto ||
example choose equals. e thanor el L =l
does not begin with
- @l < Back Next > Cancel |
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9. Next, the cell to the right of your criteria
will appear white/editable (not grayed
out). Enter your criteria, enter a
department number.

Stay on this window, be sure not to click
next yet.

10. You can see that Department is now
BOLD. This indicates you have criteria
using the Department Column and
now your next step is to add
additional criteria for Account Type.

11. Filtering data with Account Type, you
can select the drop down on the
right-side column, and it will display
available values. Choose equals, then
click the drop down and select 22.

Query Wizard - Filter Data

Filter the data to specify which rows to include in your query.
If you don't want to filker the data, click Next.

Column to filter: Only include rows where:
[~Account_Type -
equals v, A
Document_Code | » J o J
Department  And 02
Fiscal_Year l—_'] 03
20
€ and |2
|
C and |31
90

Next >

Query Wizard - Filter Data

Filter the data to specify which rows to include in your query.
If you don't want to filter the data, click Mext.
Column to filter:

Only include rows where:

Accoun_Type -Department
Amount [equals ~||[15d ]
Document_Code
Depattment @ and O Or
Fiscal_Year I E] I ;l
 And € Or
| =] =
C And € O
< Back Next > Cancel |
Query Wizard - Filter Data X

Filter the data to specify which rows to include in your query.
If you don't want to filter the data, click Next.
Calumn to fiter:

Account Type

Amount |

=l =
Trecal rear

Only include rows where:
r~Account_Type -

e | =1l =l
| 24| =
CAnd O
<Back Next > Cancel |
Query Wizard - Filter Data X

Filter the data to specify which rows to include in your query.
If you don't want to filter the data, click Mext.

Column to filter: Only include rows where:
[rceourt, Tope.
Amount equals 2| 22 =
Document_Code
Department @ And € 0r
Fiscal_Year I =l -
CAd €O
CaAad OO0
< Back Next > Cancel I
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12. Let's add one more filter, using Fiscal

Year. Create a filter where Fiscal Year ~ QuenyWizard-Fiter Data &
IS greater than 2025. Fiker the data to specily which rows to include in your query.
If you don't want to filter the data, click Next.
NOUCe that Account Type Colurnn to filter: D:'.y inTI‘i:e rows where:
. ! oot Teoe. W iscal Year
Department and Fiscal Year columns 3333#";‘;:: = ] [ =]
are in bold. I%%‘E?_ Gl R
. I =l | =
This indicates that you have created a Coand €
filter for multiple items. If you need to | ] |
. . . . . C Ar C 0
revisit any criteria, simply click on -

the column name.

o <Back |[ Nex> || cancel |

Once you have completed your criteria
and filters, click Next.

Query Wizard - Sort Order

Specify how you want your data sorted.
If you don't want to sort the data, click Next.

13. The Sort Order window will appear. Iﬁﬂm—l (3, dacseding :
. IDocumenl_Cude 'I O Discanis
We will sort the results by Document — g
Click Next. — <] € dacenin
_ =
2| < Back Net> [l Cancal |
Query Wizard - Finish X
What would you like to do next?
14. The Finish window appears. You can run | © Bsunbsiais st escef | Save Que.. |
your query in Excel and save the query £ e ceta ek ey i MEaceat s
for future re-use. Or if you are savvy
using the Query Editor, you can
customize your results further.
Click Return Data to Microsoft Excel |
then select Finish. g (wq_m i
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mport Data

Select how you want to view this data in your workbook.

B © 1able
() pivotTable Report
13 O PivotChart

15. You will then see an Import Data screen. B O Only Create Connection
Click Properties, Where do you want to put the data?
© Existing worksheet:
=SAS1 +

(O New worksheet

Add this data to the Data Model

Properties...

Connection Properties D X

Connection name: |Query from StateDW
Description:

Usage | Definition JUsed In

Connedtion type:  Database Query

Connection file: Browse...

Always use connection file

16. Se | ect th e Deﬁ n it i on ta b, an d C h ecC k th e Connection string: |DsN=StateDW::SERVER=StateDW.Finance.Utah.Gov;PORT=

5855,UID=DW;

Save password box.

Command type: saL

Command text: SELECT Accounting_lournal.Account_Type,
Accounting_lournal.Amount,
Accounting_lournal.Document_Code,
Accounting_lournal.Department,

Excel Services: Authentication Settings...
Edit Query... Parameters... Export Connection File...
Z)
17. At the warning screen, click Yes.
nsoft Exc
i The password is saved without encryption in the Excel file, making your data less secure, Are you sure you want to save the password?
Yes No
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Connection Properties O X

Connection name: Query from StateDW

Description:

Usage Definition Used In
Connection type:  Database Query
Connection file: Browse...

Always use connection file

18. At the Connection Properties screen, click OK. COmeCIon 1 o5 tteOU D= 1254 ERVER eV irance .

Command type: saL v
Command text: SELECT Accounting_Journal.Account_Type,
Accounting_Journal.Amount,

Accounting_Journal.Document_Code,
Accounting_Journal.Department,

Excel Services: Authentication Settings...

Edit Query... Parameters... Export Connection File...

d Cance

Import Data I X

Select how you want to view this data in your workbook.

= O Iable
(O PivotTable Report

19. At the Import Data screen, select how you 153 O PivotChart

want to see your data, as a Table, PivotTable [IIREL) ook Sxee coneecion
Where do you want to put the data?

Report, or PivotChart, click OK. | © Existing worksheet:
' =sAs1|
() New worksheet

=

Add this data to the Data Model

Properties... Cancel
20. It will then populate your raw data.
The directions below will be helpful if you ever want to change the query criteria.
21. Click Data > Queries & Connections.

@ Autosave D~ o 5 Bookl - Excel £ search e = [m] X
File Home Insert Draw Page Layout Formulas Data Review View  Automate  Help  Acrobat | = comments |
[ From Text/CSV  FE From Picture r 5 2] % =g & &= =22 @ E

% [& From web [ Recent Sources RE @ @ E‘ z Fker 12 'I('th% B @~ What?lf Forecast = Outline
Data~ [ From Table/Range [ Existing Connections Al [&) Stocks  Cumencies A 92 Advanced | Columns £ - Analysis > Sheet -
Get & Transform Data Queries & Connections Data Types Sort & Filter Data Tools Forecast hd
Al v i S~ v
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22. Right click on the query, select
Properties...

23. Select the Definition tab, (optional: enter
a Connection name) click Edit Query...

24. Repeat from steps 6-14 above.

Queries

Queries

& Connections

Connections

3 connections

2] Query from StateDW

=) Query from StateDW1

Refresh

X Delete

2y Properties...

Connection Properties O
Connection name] Query from StateDW11
Description:

Usage Jsed In

Connection type:  Database Query

Connection file:

Browse...

Always use connection file

Connection string: | DSN=StateDW;PWD=DW1234;SERVER=StateDW.Finance.Utah.

Command type:

Command text:

Excel Services:

Edit Query...

Gov;PORT=5855;UID=DW;

@ save password

sQL

| <

SELECT Object.Fiscal_Year, Object.Object,
Object.Object_Name, Object.Object_Extended_Description,
Object.Active, Object.Object_Class,
Object.Object_Class_Name, Object.Object_Category,

Ohiart Ohisrt Catenan: Name Nhisrt Fivad Accat Indicatar

Authentication Settings...

Parameters... Export Connection File...
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